Anki не запускается на Lubuntu 17.04, не воспроизводит звук?

Здравствуйте!

Долго мучился и заставил запускаться Anki и воспроизводить звук.

Как только я установил прогу:

sudo apt install anki

Она, если запускать её из терминала, выдавала такую ошибку:

kiman.odesa.in@kiman:~$ anki
Traceback (most recent call last):
 File "/usr/bin/anki", line 7, in <module>
 import aqt
 File "/usr/share/anki/aqt/__init__.py", line 12, in <module>
 from aqt.qt import *
 File "/usr/share/anki/aqt/qt.py", line 22, in <module>
 from PyQt4.QtWebKit import QWebPage, QWebView, QWebSettings
ImportError: No module named QtWebKit
kiman.odesa.in@kiman:~$

Дело в том, что ей не хватает некоторых старых версий пакетов. Тут можно решить проблему двумя путями:

  1. Скачать последнюю версию пррограммы с официального сайта (не DEB версию, она тоже не работает). Её можно запускать без установки как портабл версию командой:
    ./bin/anki

    Либо установить командой:

    sudo make install

    обе команды выполняются из директории с распакованной программой, естественно, т.е. сначала нужно выполнить команду:

    cd /путь/к/директории/c/распакованным/архивом/anki
  2. Установить нужные пакеты из репозиториев прошлых версий дистрибутива командами ниже.

Для начала нужно добавить в файл /etc/apt/source.list следующие репозитории:

deb http://archive.ubuntu.com/ubuntu/ xenial universe
deb http://archive.ubuntu.com/ubuntu/ xenial-updates universe

Обновить информацию о доступных пакетах:

sudo apt update

Установить необходимые пакеты:

sudo apt install python-qt4=4.11.4+dfsg-1build4 python-qt4-sql=4.11.4+dfsg-1build4

Заморозить полученные пакеты, чтобы они не обновлялись:

sudo apt-mark hold python-qt4 python-qt4-sql

Если больше ничего не нужно из старых репозиториев, удалить последние две строки в этом файле:

sudo nano /etc/apt/sourcess.list

После этого Anki должна запускаться. Но если у вас колода с аудио, оно может не работать, как у меня, тогда читайте дальше.

Anki на Lubuntu 17.04 не воспроизводит звук?

Оказывается Anki не проигрывает аудио файлы, т.к. ей нужен Mplayer, а в дистрибутиве Lubuntu 17.04 по умолчанию установлен Mplayer2 (возможно и в Ubuntu, не знаю точно). Стоит симлинк «mplayer» на «mplayer2», и если запустить в терминале команду «mplayer mp3.mp3», музыка играет, но для Anki это почему-то не срабатывает. Словом, нужно заменить программу:

sudo apt purge mplayer2

sudo apt install mplayer

Возможно, можно просто установить, не удаляя, но я уже проверять не буду, напишите в комментариях, если что), можете и ссылку на мой блог где-то поставить, буду благодарен.
Спасибо, что зашли!

Звёзд: 1Звёзд: 2Звёзд: 3Звёзд: 4Звёзд: 5Звёзд: 6Звёзд: 7Звёзд: 8Звёзд: 9Звёзд: 10 (2 оценок, среднее: 10,00 из 10)
Загрузка...

One thought on “Anki не запускается на Lubuntu 17.04, не воспроизводит звук?

Добавить комментарий

Ваш e-mail не будет опубликован.