Установка Viber на Ubuntu 20.04 и зависимость libssl1.0.0

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 viber : Depends: libssl1.0.0 but it is not installable
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

Здравствуйте!

Установил сегодня на свою Убунту 20.04 Вайбер через dpkg, он установился с ошибкой о нехватке зависимости libssl1.0.0, но запустился и работал.

Всё бы ничего, но из-за проблемы с зависимостью ничего нельзя было установить без выполнения комнды:

apt --fix-broken install

А её выполнение удаляло Viber.

Почему данной зависимости в репозитории моей верии Ubuntu 20.04 64 бит нет, я не стал разбираться, а просто пошел нашел данный пакет в репозитории другой версии, скачал и установил его.

Качал по этой ссылке:

http://archive.ubuntu.com/ubuntu/pool/main/o/openssl1.0/libssl1.0.0_1.0.2n-1ubuntu5.3_amd64.deb

Если у вас файл не качается, возможно они обновили пакет и ссылка изменилась. Посмотрите тогда новую версию файла тут:

http://archive.ubuntu.com/ubuntu/pool/main/o/openssl1.0/

Если у вас система 32 бит, тоже посмотрите свой файл по ссылке выше.

Спасибо что прочли, идеи и пожелания пишите в комментариях к этой статье, регистрация и ввод капчи не требуется.

Счастливо!

Звёзд: 1Звёзд: 2Звёзд: 3Звёзд: 4Звёзд: 5Звёзд: 6Звёзд: 7Звёзд: 8Звёзд: 9Звёзд: 10 (3 оценок, среднее: 10,00 из 10)
Загрузка...

Добавить комментарий

Ваш адрес email не будет опубликован.